Chris

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Monitoring charge question #54843
    Chris
    Participant

    Ahhhh. It came to me!!  I needed to put the negative on the load side of the shunt!    :yahoo:

    in reply to: Power issues #54204
    Chris
    Participant

    Thanks Ray!!  I have a Honda 2000 generator, so I would wager it might have trouble with the 70 Amp as well.  Perhaps the 60 is the best option.  If I replaced the OEM converter with the Progressive Dynamics 60 over the fridge, would I still get undercharged batteries like you experienced due to the long run to the batteries?  Or would the better PD converter compensate?  I just swapped out my batteries last summer to two 6 volts and installed an inverter after watching your videos.

    Thanks by the way for all of your videos!!  I too have a Cougar 5th wheel (2007), so I was super excited to find your channel and all of your how-to videos.  :yahoo:  Our RVs have a lot of similarities, and that really helps since this is our first RV.

    Thanks again!!!

    Chris

     

    in reply to: Power issues #54193
    Chris
    Participant

    Thanks Bruce for the warning!  I will look into this!

    I still would like to better understand the different AMP models.  Would the 70 AMP be too much for my 30 AMP RV?

    Thanks!!

    Chris

     

    in reply to: Power issues #54138
    Chris
    Participant

    Found an install video and I see where it would go.  Looks pretty easy!!  Yeah!!

    in reply to: Power issues #54136
    Chris
    Participant

    Hello Eddie!!  Thanks for the help.   I was afraid that it was the converter.  😥   Just missed Christmas!!

    I have heard great things for the converter that you recommended.  I see that this model is a 70 Amp, does it matter that my RV is 30 AMP  (maybe dumb question…).   Also, do I pull out the WFCO converter and put this one in it’s place?  It doesn’t seem to have breakers or fuses.  (perhaps another dumb question…).   I will search around for an install video.

    Thanks again!!

    Chris

Viewing 5 posts - 1 through 5 (of 5 total)